~—=Web-Read) _.——”
Technical Note — Oracle Database in x64 Operational Systems ,nausoﬂr
February 24, 2014 — Rev.A ‘
©Copyright InduSoft Systems LLC "

Oracle Database in x64 Operation Systems

Introduction

This document intends to clarify the steps needed on installing Oracle Database Express in a x64 Operational
Systems, configuring Indusoft connection and setting up the StADOSuvr.ini file. This document also intends to clarify
the steps needed on connecting to the Oracle Database Server and installing the Oracle client.

The procedure here described is not the only solution available, although is one verified by InduSoft.

Notice that Oracle Database can be installed normally in x86 Operational Systems. Even so it is necessary to setup

StADOSwvr.ini.

Initial Considerations

Besides InduSoft tools all external software kits here related are available free of charge and easily found on internet.
The source websites are listed at the end of this document.

During this process, some entries of the original system registry will be changed. Therefore, make sure you have full
administration privileges. It is also strongly recommended that the user creates a backup of the current registry in case
something goes wrong.

Configuring the StADOSuvr.ini
The steps described below will guide users to configure the StADOSvr.ini.
1. From a workstation with InduSoft Web Studio installed, run the Notepad as Administrator.

2. File->Open and select the StADOSuvr.ini from the BIN folder of the installation directory (e.g.
C:\Program Files\InduSoft Web Studio v7.0\BIN\StADOSuvr.ini):

3. In Count, add one to the value configured. (e.g. Count=8 to Count=9);
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" StADOSwr - Notepad
P

File Edit Format View Help
[Providers]

DefaultsaveMSec=3

Defaultassembly=5ystem. Data
pefaultConnectionClass=5ystem.Data.0leDb.0lebbConnection
DefaultDataadapterClass=5ystem.Data.0leDb.0leDbDataadapter
pefaultCommandBuilderclass=5ystem.Data.0leDb.0lebbCommandBuilder
DefaultvaluesString=EGvalue

pefaultvalueaddNumber=1

DefaultBool Type=INTEGER

DefaultIntegerType=INTEGER

DefaultRealType=REAL

DefaultstringType=VARCHAR(255)
DefaultTimeStampType=DATETIME

pefaultsingleConnection=0

4. After the last Provider, add the following one:

Assembly9=0racle.DataAccess.Client
ConnectionClass9=Oracle.DataAccess.Client.OracleConnection
DataAdapterClass9=0Oracle.DataAccess.Client.OracleDataAdapter
CommandBuilderClass9=Oracle.DataAccess.Client.OracleCommandBuilder
ValueString9=Value

ValueAddNumber9=1

ValueStringPrefix9=:

BoolType9=Number(1)

IntegerType9=Number(10)

RealType9=Number

StringType9=VARCHAR(255)

TimeStampType9=TIMESTAMP(0)

EnableTop9=0

EnableRowCount9=1

NOTE: The number in front of the parameters must be the same as the value configured in Count.
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”j StADOSvr - Notepad - -

File Edit Format View Help

Aﬁﬁemb1ysﬂw¥5q1.nata
ConnectionClass&=Mysqgl.Data.MysqlClient.MysqlConnection
DataadapterClass8=Mysql.Data.MysqlClient.MysglDataadapter
Commandéuilderclass&=Mysql. Data. MysqlClient. MySqglCommandBuilder
valuestring8=Evalue

valueaddNumber §=1

EnableTop8=0

EnableLimit8=1

der9=MsDA0RAZ
Assembly9=0racle. Datadccess.Client
ConnectionClass9=0racle.Dataaccess. Client.OracleConnection
DatasdapterClass9=0racle.DataAccess.Client.Oraclebatasdapter
CommandBuilderClass9=0racle.Dataaccess.Client.OracleCommandBui lder
valuestringd9=value
valueaddNumber9=1
valuestringpPrefixd9=:

BoolTyped=Number (1)

Integer TypeS=Number (10)
Rea] Type9=Number
StringType9=VARCHAR(255)
TimestampTyped=TIMESTAMF (0)
EnableTop9=0
EnableRowCount9=1

5. Save and close it.

Installing the Oracle Database Client

1. Download the Oracle Database Client x86 available in the following link:

http://www.oracle.com/technetwork/database/enterprise-edition/downloads/112010-win32soft-
098987.html

2. Extract the files;
3. Run the setup.exe as Administrator;

4. Select the Administrator option;
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r‘éﬂ Oracle Client Installer - Configurando o Cliente - Etapa 1 de 6 l =R é |
Selecionar Tipo de Instalagao DEACLE 11g
DATABASE

/‘"\ Selecionar Tipo de Instalagio Que tipo de Instalacao vocg deseja?

T Especificar & Localizacdo dalnsta| () IngtardClient (174, 0ME)

I

Instala o Software Instant Client

@ (&) lsdministrador (1,0268)

l Instala a conzole de gerencismento, ferramentas de gerenciamento, servigos de rede, utiltarios & software
cliente basico.

5. Click in next;

6. In Oracle Base configure:
C:\app\oracle
7. In Software Localization configure:
C:\app\oracle\product\11.2.0\client_1
8. Click in next;
9. Follow the steps to install the software;
10. Copy the tnsnames.ora from the Oracle Server installation to the following path:

C:\app\oracle\product\11.2.0\client_1\network\admin\

11. Open the tnsnames.ora. In HOST, configure the IP of the server computer.

-

mj tnsnames - Motepad

File Edit Format View Help

# tnsnames.ora Network Configuration File: E:‘app‘Administrator‘product’1l.2.0"dbl
# Generated by oracle configuration tools.

DBORACLE =
(DESCRIPTION =
{ADDRESS = (PROTOCOL = TCP PORT = 1521))
(CONNECT_DATA =
{SERVER = DEDICATED)
({SERVICE_NAME = DBOracle)

)
)
ORACLR_CONNECTION_DATA =
(DESCRIPTION =

(ADDRESS_LIST =
{ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521))
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12. Reboot the computer;

13. Open the InduSoft Web Studio;
14. Click on the menu Ribbon->Project->Options->Default Database;
15. The connection string should be:

Provider=MSDAORAZ2; Data Source=DBNAME
(e.g. Provider=MSDAORAZ2; Data Source=INDUSOFT)

16. In Username and Password, configure it based on the Username and password of the Oracle
Server.

# ° Default Database Configuration I,iE-J

Settingz

Databaze: | Primary -

Connection sting:  Provider=MSDADRAZ; Data Source=Ih | ..

L zer namme: induzoft
Pazgwiord: [IITITT T
Retry Interval: 120 Secs. Advanced...
Ok ] | Cancel |
17. Click OK.

Installing the Oracle Database Express

1. Download the Oracle Database Client x86 available in the following link:

http://www.oracle.com/technetwork/database/database-technologies/express-
edition/downloads/index.html

2. Extract the files;
3. Run the setup.exe as Administrator;
4. Specify a password to the Database;

5. During the installation, an error will occur because the Oracle Database Express is not
certified to run in a X64 computer;
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FErrCl - s — ﬂ-‘

O installer ndo péde instanciar o arquive
_I—'h T Users\VINICI-1.CHIVAppDatat Localh Temph{73007218-3022 -4 D5E- AE
AA-12931 ABOFABNKEY XE.reg. O arquive pode ndo existir,

[ ]

6. You can force the Oracle installation if you create the Key XE.reg file according the next
steps.

7. Open the path of the error, in this case:
“CAUsers\VINICI~1.CHNAppData\Local\Temp\{7300721B-3D22-4D5E-AEAA-
12931A839FABNKEY.XE.reg”

8. Create a copy of the OracleMTSRecoveryService.reg file in this folder;

9. Rename the file to: KEY_XE.reg;

| . v Computer ¢ Local Disk (C:) » Users » Vinicius.Chicone » AppData » Local » Temp » {7300721B-3D22-4D5E-AEAA-12931A839FAE]}

hd Include in library = Share with + Burn Mew folder
ites Mame . Date modified Type Size
ktop % _isres_0x0416.d1I 24/02/2014 16:22 Application extens... 324 KB
wnloads % _isuser_0x0416.dlI 240272014 16:22 Application extens... 256 KB
ent Places %] ChkPortDII2.dll 24/02/2014 16:22 Application extens... 44 KB
phbox %, GetHostnameDll.dll 240272014 16:22 Application extens... 40 KB
InstallW52K5 24/02/2014 16:22 Windows Batch File 1KB
ies (2] 1SBEWE4 24/02/2014 16:22 Application 105 KB
umnents | ISRT.dll 24/02/2014 16:22 Application extens.., 256 KB
sic @ KEY_XE 24/02/2014 16:22 Registration Entries 1KB
ures W License 24/02/2014 16:22 Rich Text Format 22 KB
=05 |&| OracleHorizentalBanner 24/02/2014 16:22 Bitrap image S KB
@ OracleMT5RecoveryService 24/02/2014 16:22 Registration Entries 1KE

10. Click on the OK button in the error installation to continue;

11. Open the path of your client installation: C:\app\oracle\product\11.2.0\client_1 and copy the
tnsnames.ora and sqlnet.ora;

12. Open the Local Disk Folder (C:\);

13. Create a new folder tnsora;
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14. Paste the files in this new folder;

|/ v Computer » Local Disk (C:) » tnsora

- Include in library - Share with - Burn Mew folder

| Mame Date modified
ites

ktop | 7] sglnet 24/02/2014 15:50
wnloads |7 tnsnames 24/02/2014 16:16

e Ty, | |-

15. Open the tnsnames.ora file;

16. Now you need to include the XE connection, so replicate the first configuration (DBORACLE
connection) in the end of the file content;

E tnsnames - Notepad y

—

File Edit Format View Help

# tnsnames.ora Network Configuration File: E:‘app‘Administrator'prod
# Generated by oracle configuration tools.

DBORACLE =
(DESCRIPTION =

|I ORACLR_CONNECTION_DA
(MFSCRTPTTON =

17. Change the name and the Service_Name to XE and the HOST to localhost;
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-
- LR -

“| tnsnames - Motepad
p

File Edit Format Wiew Help

# Generated by Oracle configuration tools.

DBORACLE =
(DESCRIPTION =

(CONNECT_DATA =
(SERVER = DEDICATED)
(SERVICE_NAME = DBOracle)

)
)
ORACLR_CONNECTION_DATA =
(DESCRIPTION =

(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROCL321))

{CONMECT_DATA =
({5ID = CLREXtProc)
(PRESENTATION = RO)

)
)
LISTENER_DEORACLE =
(ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT =

XE =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = localhost) (PORT
(CONNECT_DATA =

{SERVER = DEDICATED)
(SERVICE_NAME = XE)

18. Save and close it.

19. Open the Oracle Express installation folder:
C:\oraclexe\app\oracle\product\11.2.0\server\network\ADMIN

20. Copy the listener.ora file;

21. Paste it in the C:\tnsora\ folder;

(ADDRESS = (PROTOCOL = TCP)(HOST = 10.12.136.70)(PORT = 1521))

1521))

= 1521))

# tnsnames.ora Network Configuration File: E:‘\app‘Administrator’pro
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./ v Computer » Local Disk (C:) » tnsora

- Include in library - Share with = Burn Mew folder

stes Mame : Date modified

ktop | 7| listener 240272014 16:32 I
wnloads |7 =glnet 24/02/2014 15:50 !
ent Places |7 tnsnames 24/02,/2014 16:16 I

b

22. Open the Control Panel->System and Security->System;
23. Select Advanced System Settings;

L TEE—

@ 'I;‘ » Control Panel » System and Security » System

Control Panel Home . — .
View basic information abot

'yi" Device Manager Windows edition
® Remote settings Windows 7 Professional
¥ System protection Copyright © 2009 Microsoft Cory

fj Advanced system settings

24. Select Environment Variables...;
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Tools for Automation ‘

r Il
System Properties ..r u
i,

Computer Name | Hardware| Advanced |51rstam Protection | Hﬂmta|

You must be logged on as an Administrator to make most of these changes.

Performance
Visual effects, processor scheduling, memary usage, and virtual memony

Settings

Iser Profiles
Desktop settings related to your logon

ings...

ﬁ

Startup and Recovery
System startup, system failure, and debugging information

ngs

Environmert Varahles. ..

I

25. In System Variables, select New;

¥

L UL S SR u

Iser variables for Vinicius. Chicone

Variable Value

MOZ_PLUGIN_P... C:\Program Files (x86)\Foxit Softwarel...

TEMP %USERPROFILE%\AppData\Local\Temp

TMP %USERPROFILE % \AppDataLocal Temp
New.. || Edt.. || Delete

System variables

Variable Value il
caminho C:\oradexe\apploradeproductill. 2.04... L4
CLASSPATH C:\Program Files (x86)Javaljre7Yible...
ComSpec C:\Windows\system32\omnd. exe
FP_NO_HOST C... NO -
New.. |l Edt. || Delete |
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26. In Variable Name, configure: tns_admin;

27. In Variable Value, configure: C:\tnsora;

~

Mew System Variable

Variable name:

Variable value:

tns_admin

C:\insora|

[ Ok ] [ Cancel

28. Click OK;

29. Reboot the computer;

30. Open the InduSoft Web Studio;

31. Click on the menu Ribbon->Project->Options->Default Database;

32. The connection string is:

Provider=MSDAORAZ2; Data Source=XE

33. In Username configure system, and in Password configure the password configured in the
Oracle Express installation;

-

B ° Default Database Cenfiguration

==

Settingz

Connection string;

Provider=MSDADRAZ; Data Source=l | .. |

IJzer name: spsten
Pazgwiord: [IITITT T
Retry Interval: 120 Secs.
ak. ] [ Cancel ]
34. Click OK.
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Final Considerations

The procedure here described installs Oracle Express and Oracle Client to run in x64 Operational Systems. It has
been successfully executed on three different Microsoft systems including Windows Server 2008 R2, Windows 7 and
Windows 8.
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